Installation de PHPUnit et mise à jour de PEAR sous MacOsX

Quand le Snow Leopard n'aime plus les tests unitaires.

29 avril 2011

Récemment j'ai voulu installer la dernière version de PHPUnit sur un système Snow Leopard.

Comme il est recommandé de le faire j'ai utilisé PEAR (PHP Extension and Application Repository) pour installer PHPUnit mais, au milieu de dizaines de lignes, j'ai obtenu un message d'erreur :

phpunit/PHPUnit requires PEAR Installer (version >= 1.9.2), installed version is 1.8.0

Il faut donc mettre à jour PEAR avant de pouvoir installer PHPUnit.

Mise à jour de PEAR

	# On force PEAR à s'installer lui même. 
	# Note : j'ai essayé avec pear upgrade pear mais ça n'a pas fonctionné.
	pear install --force pear
	

Il ne reste qu'à installer PHPUnit.

Installation de PHPUnit

	# On indique à PEAR ou il peut trouver les paquets de PHPUnit.
	pear channel-discover pear.phpunit.de

	# Il ne reste plus qu'à lancer l'installation de PHPUnit
	pear install --force --alldeps phpunit/PHPUnit
	
Par
Créateur et administrateur.

Dans la même catégorie

Comment restaurer les sms corrompus d'un iPhone ?
Comment simuler un iPhone ou un iPad pour le développement web mobile ?
OS X Lion : Comment copier coller depuis le mode coup d'oeil ?
Afficher les fichiers cachés sur mon mac.
Créer un réseau wifi avec un mac
Redémarrer Apache HTTP Server sous Mac Os X
Se connecter en root sur MacOsX
Transférer des photos depuis un iPhone / iPad / iPod sur un Mac.

Commentaire(s)